Go Back   Genesis Coupe Canada > Alberta > Member's Rides

Reply
 
Thread Tools Display Modes
  #11  
Old 07-09-2011, 02:37 PM
GenCoupe2.0tGt GenCoupe2.0tGt is offline
2010 2.0T GT MT, Karussell White
Senior Member
 
Join Date: Sep 2010
Location: Red Deer Alberta
Posts: 348
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by ts-jersey1 View Post
2011- brand new- landed in Apr had like 34kms when i picked it up
really?? thats very unusual thank god for warranty
Reply With Quote
  #12  
Old 07-09-2011, 02:39 PM
GenCoupe2.0tGt GenCoupe2.0tGt is offline
2010 2.0T GT MT, Karussell White
Senior Member
 
Join Date: Sep 2010
Location: Red Deer Alberta
Posts: 348
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Phatdhad View Post
looks like they may cover my paint peel!!

as for VHT....I used 2 coats on my tail lights and love them!
with 2 light coats the inside housing is still easily visible and nobody has any issues seeing the tails.
ahhh congrats hope they do a better job this time round
from the looks of it they just painted the bumper and didnt even prime it

even on my car in the rock chips i have doesnt appear to have any primer coat at all no wonder it just flakes off
Reply With Quote
  #13  
Old 07-11-2011, 09:09 AM
GenCoupe2.0tGt GenCoupe2.0tGt is offline
2010 2.0T GT MT, Karussell White
Senior Member
 
Join Date: Sep 2010
Location: Red Deer Alberta
Posts: 348
Thanks: 0
Thanked 0 Times in 0 Posts
Default

well im officially fucked went into work today and apparently having a injured back is a reason to get fired over so yea....

i have a week to come up with my insurance money and then another two weeks to find another job and to make some quick cash to make my next car payment....

yay!
Reply With Quote
  #14  
Old 07-13-2011, 05:24 PM
GenCoupe2.0tGt GenCoupe2.0tGt is offline
2010 2.0T GT MT, Karussell White
Senior Member
 
Join Date: Sep 2010
Location: Red Deer Alberta
Posts: 348
Thanks: 0
Thanked 0 Times in 0 Posts
Angry

well gary shmoe's called me up today said they got the part in and replaced it on my car and it was good to go....

so i went and picked it up drove like not even around the corner and yea.. still bogging out no boost at all.....

the tech came out and hooked his computer up to and said everything is fine
so i took him for a drive and showed him exactly how fucking underpowered it is and he was stumpped i think hahahahaha for fuck sake... you call yourself a mechanic yet you cant even figure out why my car has like no power....
i swear they cant do fuck all with out a laptop to guide them

think i might take it to my buddy darrell who's a "real" mechanic and knows what the fuck he's doing with out a bloody lap top to tell him whats going on
Reply With Quote
  #15  
Old 07-20-2011, 05:22 PM
GenCoupe2.0tGt GenCoupe2.0tGt is offline
2010 2.0T GT MT, Karussell White
Senior Member
 
Join Date: Sep 2010
Location: Red Deer Alberta
Posts: 348
Thanks: 0
Thanked 0 Times in 0 Posts
Default

recent update:

ok so now they're saying my turbo has kicked the bucket so now they're going to replace my turbo parts on order should be here by the 26th hopefully.... and then add another week or two ontop of that for them to actually start working on it... seein as how its warranty work it will be left for last

i really hope this works or im just going to drop it on them and take a bad credit hit not like i can really afford to keep the thing anymore anyways..

ive applied for EI but who knows how much it will be?? and when i will be recieving it??

stilll looking for work not sure what? seeing as how my back is in such rough shape trying to get something that isnt so labour intensive

anyways think i need to take it easy for a bit

if you know of something that would intrest me?? let me know
Reply With Quote
  #16  
Old 07-20-2011, 10:23 PM
kav-ron kav-ron is offline
2010 2.0T GT , Acqua Minerale Blue
Senior Member
 
Join Date: Apr 2011
Location: Fort McMurray
Posts: 140
Thanks: 0
Thanked 0 Times in 0 Posts
Default

First off, I'd bring that shit to the labour board... They can't fire you for that.. If you fucked your back you should be on workers comp.

Secondly, I really hope everything works out!
__________________
2010 Acqua Minerale Blue 2.0T GT
Reply With Quote
  #17  
Old 07-20-2011, 10:56 PM
TurtleJeff's Avatar
TurtleJeff TurtleJeff is offline
2010 2.0T Premium AT, Mirabeau Blue
Senior Member
 
Join Date: Nov 2009
Location: Edmonton, Ab
Posts: 333
Thanks: 36
Thanked 3 Times in 3 Posts
Default

Fully agree, if you've been employed more than 3 months they can't fire you like that. Massive wrongful dismissal case. I once took an employer to the labour board about not paying me my overtime, got an extra $700 out of them...

Second, keep us up to date with the car, I hope you can find work and keep the car (if you want to).

EI depends on how much you were making, it's a percentage of what your last wage was, the max I think is still about $400 per week. That's if you qualify, but I think technically to qualify you need to have been laid off... But if you qualify and have all the papers in order it could be within a couple weeks...
Reply With Quote
  #18  
Old 07-21-2011, 09:06 PM
GenCoupe2.0tGt GenCoupe2.0tGt is offline
2010 2.0T GT MT, Karussell White
Senior Member
 
Join Date: Sep 2010
Location: Red Deer Alberta
Posts: 348
Thanks: 0
Thanked 0 Times in 0 Posts
Default

yea i think im eligible for EI i got my access number in the mail the other day start reporting next week so hopefully that will save my ass for a bit while im searching for a new job

i was only getting paid like 15$ an hour so my EI will probly only be about 5-600$

i would like nothing more in the world to keep my car but if i cant afford it i cant really afford it??

in other news my insurance has gone down lmao....
perfect timing

and some more bad news my computer has sh!t the bed im on my dad's right now but there goes another 800$ for a new computer
Reply With Quote
  #19  
Old 08-29-2011, 08:14 AM
GenCoupe2.0tGt GenCoupe2.0tGt is offline
2010 2.0T GT MT, Karussell White
Senior Member
 
Join Date: Sep 2010
Location: Red Deer Alberta
Posts: 348
Thanks: 0
Thanked 0 Times in 0 Posts
Default

well it is now almost september and still no car..... no word of it being fixed... no word period... anyone else in red deer i recommend you take your car to another hyundai dealership cause clearly they dont give a flying fuck about their customers

i went to check on my car the other day and now it wont even start......
funny it ran when i dropped it off....
Reply With Quote
  #20  
Old 08-29-2011, 10:48 AM
LeonardO LeonardO is offline
2010 3.8 Premium MT, Acqua Minerale Blue
Senior Member
 
Join Date: Sep 2010
Location: Edmonton, AB
Posts: 263
Thanks: 6
Thanked 7 Times in 7 Posts
Default

The battery is probably just dead. Did they at least tell you what they were planning to do with it and how long it might take?
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 02:24 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.