Go Back   Genesis Coupe Canada > General > Technical

Reply
 
Thread Tools Display Modes
  #1  
Old 07-29-2012, 12:04 PM
bowlofRice's Avatar
bowlofRice bowlofRice is offline
2010 2.0T Premium MT, Nordschleife Grey
Member
 
Join Date: May 2012
Location: calgary
Posts: 58
Thanks: 0
Thanked 1 Time in 1 Post
Default transmission grind problem

hey guys, i was just wondering if anyone has experienced the transmission grind problem.. and if so how did you go about gettin it fixed?


thanks!
ryan
Reply With Quote
  #2  
Old 07-29-2012, 12:38 PM
BHbomber's Avatar
BHbomber BHbomber is offline
2010 3.8 GT MT, Bathurst Black
Senior Member
 
Join Date: Jul 2009
Location: Edmonton
Posts: 707
Thanks: 1
Thanked 7 Times in 7 Posts
Default

Take it to the dealer and let them see it and maybe they'll replace it for you.
Reply With Quote
  #3  
Old 07-31-2012, 05:27 PM
bowlofRice's Avatar
bowlofRice bowlofRice is offline
2010 2.0T Premium MT, Nordschleife Grey
Member
 
Join Date: May 2012
Location: calgary
Posts: 58
Thanks: 0
Thanked 1 Time in 1 Post
Default

already taken it, told me they couldnt replicate the problem after 20 min
Reply With Quote
  #4  
Old 07-31-2012, 06:00 PM
BHbomber's Avatar
BHbomber BHbomber is offline
2010 3.8 GT MT, Bathurst Black
Senior Member
 
Join Date: Jul 2009
Location: Edmonton
Posts: 707
Thanks: 1
Thanked 7 Times in 7 Posts
Default

Take it back and you drive the car with the tech in the passenger seat. You can hear it without having to drive. It usually happens when the rpm are above 2500. Tell them that also.
Reply With Quote
  #5  
Old 11-05-2012, 08:23 PM
Toemee's Avatar
Toemee Toemee is offline
2011 3.8 Premium MT, Bathurst Black
Member
 
Join Date: Nov 2012
Location: Ontario
Posts: 54
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Warm up car, cruise at 3000rpm, shift at 3000rpm or higher, stop shifting without using the clutch. Problem solved.
Reply With Quote
  #6  
Old 08-09-2015, 07:55 PM
sturbs87 sturbs87 is offline
2010 3.8 Base MT, Mirabeau Blue
Junior Member
 
Join Date: Aug 2015
Location: calgary
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default clutch grinding problem

My clutch just stated grinding, shifting from 4th to 5th.
These are horrible cars, i've had nothing but problem after problem.
had door rattle, now the back window squeeks, wears the tires out way too fast, ipod/mp3 players hookup doesn't work.
the body panelling is way too thin, auto body mech told me they are the worst out there, and see way too many hyundia's in the body shop

They deprecate way too much, for a sports car like this it should hold some value after 5 years but the dealers only give you 12000 for it and it seems to be a hard seller
piece of shit car says adam sandler
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 06:15 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.