Go Back   Genesis Coupe Canada > Alberta > Member's Rides

Reply
 
Thread Tools Display Modes
  #1  
Old 06-29-2011, 10:36 PM
GenCoupe2.0tGt GenCoupe2.0tGt is offline
2010 2.0T GT MT, Karussell White
Senior Member
 
Join Date: Sep 2010
Location: Red Deer Alberta
Posts: 348
Thanks: 0
Thanked 0 Times in 0 Posts
Default more then blow by???

well i think my car is fawkered i knew i had a bit of oil blow by but not this serious.....

just tonight like half an hour ago my engine started bogging out really bad
and i mean really bad there is like no throttle responce at all
almost seems like constant turbo lag
so i pulled off the upper intercooler pipe and wow.... it's just filled with oil...

i dunno what the f*k im going to do... dropped it off a gary shmoe's
but i highly doubt they will cover it under warranty

might just tell them to stick it where the sun dont shine
cant believe im paying for something thats barly even a year old and already having engine problems.....
Reply With Quote
  #2  
Old 06-29-2011, 11:01 PM
TurtleJeff's Avatar
TurtleJeff TurtleJeff is offline
2010 2.0T Premium AT, Mirabeau Blue
Senior Member
 
Join Date: Nov 2009
Location: Edmonton, Ab
Posts: 333
Thanks: 36
Thanked 3 Times in 3 Posts
Default

Holy fucking shit dude! I'm so sorry to hear this. Any idea wtf is wrong? Please keep us updated. I don't see why it shouldn't be warranty, unless they can prove it was caused by neglect, misuse, or an aftermarket mod. Please keep us all updated.
Reply With Quote
  #3  
Old 06-29-2011, 11:20 PM
GenCoupe2.0tGt GenCoupe2.0tGt is offline
2010 2.0T GT MT, Karussell White
Senior Member
 
Join Date: Sep 2010
Location: Red Deer Alberta
Posts: 348
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by TurtleJeff View Post
Holy fucking shit dude! I'm so sorry to hear this. Any idea wtf is wrong? Please keep us updated. I don't see why it shouldn't be warranty, unless they can prove it was caused by neglect, misuse, or an aftermarket mod. Please keep us all updated.
my guess??? either a clogged check valve?? or faulty PCV valve???
who knows....
was working fine this morning and then after i got home from work i went to go buy an ice cream from dairy queen and i noticed my engine was bogging out quite a bit so i aborted that idea turned around and came home and started pulling my intake appart

dont have any mods pretty well stock i did the intake silencer delete but thats got nothing to do with oil filling up my intercooler and intake pipe
I dont really abuse my car to much sure i like to go fast but i dont bag the crap out of it

and I dont neglect any of my vehicles i keep monthly maintenance up to date
i can hardly stand to go a few days with out washing my car lmao let alone neglecting it
Reply With Quote
  #4  
Old 06-30-2011, 09:23 AM
darkstar4100 darkstar4100 is offline
2010 2.0T Base , Nordschleife Grey
Member
 
Join Date: Oct 2009
Location: medicine hat
Posts: 49
Thanks: 0
Thanked 0 Times in 0 Posts
Default

That sounds like the seals in your turbo are gone it should be covered under warentee as long as the turbo has not been modifyed if they wont cover it the rebuild kits only 100$
Reply With Quote
  #5  
Old 06-30-2011, 05:57 PM
GenCoupe2.0tGt GenCoupe2.0tGt is offline
2010 2.0T GT MT, Karussell White
Senior Member
 
Join Date: Sep 2010
Location: Red Deer Alberta
Posts: 348
Thanks: 0
Thanked 0 Times in 0 Posts
Default

well i got a call from them today they say they're going to order a waste gate valve for it??? its not fixed yet but that might be the problem?

and then she went on to tell me that the oil build up in the intercooler pipe is normal hahahahahahaha are you kidding me? normal my ass....
im no mechanic but i know enough to know that there should be nothing but air going through that intercooler pipe probly wont see it back till next week sometime....
im driving my new winter beater till then..... yes i said new winter beater :P finally sold that POS explorer
picked up a 2001 kia sportage for 2,200$ seems to be a gooder will have to see once it hits -40
Reply With Quote
  #6  
Old 06-30-2011, 06:05 PM
deRost deRost is offline
2010 2.0T Premium ,
Senior Member
 
Join Date: Sep 2009
Location: Edmonton
Posts: 103
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Unless you install an oil catch can, you will get some oil vapor and a little bit of buildup in your piping. The valve cover vents through a hose into the intake piping.

As far as the wastegate goes, if it was jammed open it would prevent your turbo from spooling up and you will run very sluggishly.
Reply With Quote
  #7  
Old 06-30-2011, 11:17 PM
GenCoupe2.0tGt GenCoupe2.0tGt is offline
2010 2.0T GT MT, Karussell White
Senior Member
 
Join Date: Sep 2010
Location: Red Deer Alberta
Posts: 348
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by deRost View Post
Unless you install an oil catch can, you will get some oil vapor and a little bit of buildup in your piping. The valve cover vents through a hose into the intake piping.

As far as the wastegate goes, if it was jammed open it would prevent your turbo from spooling up and you will run very sluggishly.
ahhh thanks for the tip very well could be?? my friend who is a tuner does alot of jdm turbo cars thinks it might be the seals of the turbo its self?

but i dont think gayrmoe's even checked the intercooler pipe they checked the intake pipe from the air box down not the U pipe behind it that goes to the intercooler i pulled that one off and it was like soaking inside
the intake from the box down was minor but still was being burnt up through the turbo spitting it out the exhaust has done so since day 1

spoke of this in another thread a while ago
Reply With Quote
  #8  
Old 07-02-2011, 01:26 AM
Snoopy0812's Avatar
Snoopy0812 Snoopy0812 is offline
2010 2.0T Base MT, Mirabeau Blue
Member
 
Join Date: Jun 2010
Location: Saskatchwan
Posts: 92
Thanks: 0
Thanked 1 Time in 1 Post
Default

upper as in hot side or cold side?

If it's oily on the hotside then turbo seals, if it's cold side then it's most likely faulty PCV valve.
Reply With Quote
  #9  
Old 07-02-2011, 09:54 AM
GenCoupe2.0tGt GenCoupe2.0tGt is offline
2010 2.0T GT MT, Karussell White
Senior Member
 
Join Date: Sep 2010
Location: Red Deer Alberta
Posts: 348
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Snoopy0812 View Post
upper as in hot side or cold side?

If it's oily on the hotside then turbo seals, if it's cold side then it's most likely faulty PCV valve.
its the metal pipe with like a rubber coating on it
on the passenger side just behind the air filter box i think thats the hot side?
so yeaa lol most likely turbo seals are shot.....
Reply With Quote
  #10  
Old 07-07-2011, 06:43 PM
TurtleJeff's Avatar
TurtleJeff TurtleJeff is offline
2010 2.0T Premium AT, Mirabeau Blue
Senior Member
 
Join Date: Nov 2009
Location: Edmonton, Ab
Posts: 333
Thanks: 36
Thanked 3 Times in 3 Posts
Default

What's the latest on your car man?
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 07:34 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.